UKcms

你会喜欢的PHP7内容管理系统

UKcms v1.1.2

UKcms二次开发需要具备哪些基础

假设你完全没有接触过php,那么你需要找到一个网站:W3Cschool,相信大部分初学者都是从这里入门:http://www.w3school.com.cn/php/

在清楚php基础语法后,你需要清楚MVC概念,多看一些优秀的开源框架,例如:Laravel、Yii、thinkphp等。在这里我推荐thinkphp5,并非tp更加优秀,其实框架之间各有特色难分伯仲,使用框架的目的就是可以让你更加快速的开发项目,我们选择框架是根据项目具体情况而定的,UKcms选择tp5框架是因为它更加符合国情,国内有大量用户,学习资料也相当丰富。当然如果你是出于学习目的也可以不使用框架使用原生php或者自己写一套简单的框架进行开发。

这里回到主题,如果你想用ukcms进行二次开发增加功能的话,你只需要学会使用thinkphp5.1并且掌握一些前端基础即可



UKcms最新版本

环境要求:PHP 5.6+
版本:1.1.2
大小:14.1M
更新时间:2018年1月29日

安装包下载 PHP集成环境
最新发布